How to install numpy and scipy on Windows XP [closed]

I have a problem installing Numpy and Scipy from

http://www.scipy.org/Installing_SciPy/Windows

I went to download page and downloaded .exe files for Python26. I have Python26 on my machine. After installation, I tried

>>> import nympy, scipy
Traceback (most recent call last):
File "<stdin>", line 1, in <module>
ImportError: No module named nympy
>>>

How to proceed?


Asked by: Chloe126 | Posted: 06-12-2021






Answer 1

try with numpy instead of nympy

Answered by: Ada773 | Posted: 07-01-2022



Similar questions

python - How do I install SciPy on 64 bit Windows?

How do I install SciPy on my system? For the NumPy part (that SciPy depends on) there is actually an installer for 64 bit Windows: numpy-1.3.0.win-amd64-py2.6.msi (is direct download URL, 2310144 bytes). Running the SciPy superpack installer results in this message in a dialog box:...


Error when install python mysql module on windows?

When i try to install mysql on windows i get this error MySQL-python-0.9.2&gt;python setup.py build running build running build_py running build_ext building '_mysql' extension error: Unable to find vcvarsall.bat


Install Plone egg as a Python module on Windows

I have a Plone site (Plone version 3.1.2) that I need to install a product called GrufSpaces on - (http://plone.org/products/grufspaces). However, it is a production site and so I can't easily take it down to upgrade Plone to 3.2+ in order to use buildout; using buildout would allow me to easily add Grufspaces (collective.groupspace.roles etc) as ...


python - How to install NumPy on Windows 64?

NumPy installer can't find python path in the registry. Cannot install Python version 2.5 required, which was not found in the registry. OK I have to modify the registry? I already modified %PATH% to point to the Python25 installation directory.


python - Install Trac on 64bits Windows 7

I'm configuring a new Developing Server that came with Windows 7 64bits. It must have installed Trac with Subversion integration. I install Subversion with VisualSVN 2.1.1, clients with TortoiseSVN 1.6.7 and AnkhSVN 2.1.7 for Visual Studio 2008 SP1 integration. All works fine! my problem begun when going to Trac installation. I install python 2.6 all fine. Trac hasn't a x64 windows installer...


python - Steps on howto install PySide on windows

I followed what they said at pyside.org but somehow i can't get it to work. I downloaded the two files that they are linking from their site (qt libraries and pyside for python 2.6) When I try one of their examples I get the following message: Traceback (most recent call last): File "2dpainting.py", line 28, in &lt;module&gt; from PySide.QtCore import * ImportError: DLL load failed: The specif...


How to install both Python 2.x and Python 3.x in Windows

I do most of my programming in Python 3.x on Windows 7, but now I need to use the Python Imaging Library (PIL), ImageMagick, and wxPython, all of which require Python 2.x. Can I have both Python 2.x and Python 3.x installed in Windows 7? When I run a script, how would I "choose" which version of Python should run it? Will the aforementioned programs be able to handle multiple versions of Python installed at once? I...


python - How do I install IMDbPY on Windows?

I would like to start using IMDbPY but I can't find a Windows installer on their site. What is the most simple way to install it? Is there a way to install it using my Python interpreter?


How to install Python for Apache on Windows?

I'm looking for the fast, easy (all default settings) way of installing Python on my windows machine so that Apache can use it. I currently have a Windows 7 installation with Apache and PHP working. I want to try and make some simple web pages in Python, just to play around with Python for a bit and learn a thing or two. I downloaded and installed Python 3.2 Python 2.7.2 (As advised below). What do I do ne...


Install Python Fabric on Windows

Closed. This question is off-topic. It is not curre...


python - How to get pip install PIL to work with pypy on windows 7

This works outright on a linux VM I have sitting around but running "pip install pil" under pypy on windows 7 complains about things being defined multiple times: ~\Windows\v7.1\include\basetsd.h(76) : warning C4114: same type qualifier used more than once Fixing these by editing the installed PIL source to #undef INT8/16/32 UINT8/16/32 on windows will resolve that issue but finally end up with: LIN...


python - How to install gevent on Windows?

I'm trying to install gevent on Windows. In order to do that, I've downloaded and compiled libevent, then I run pip install gevent and get an error: Please provide path to libevent source with --libevent DIR. How can I pass the libevent option to setup.py using pip? Thanks in advance, Ivan. UPD: running pip install gevent --install-optio...


What is the best way to install python on Windows

I have an existing python3 installation in Windows, but things aren't really configured right. The main problem comes down to installing new packages. I am behind an authenticating proxy and the way I install packages is by manually downloading them and running python setup.py install. This works fine for some packages, but then there are some which use easy_install to automatically download dependencies, a...


python - install OSQA using xampp on windows 7

can anyone tell me that how can i install osqa on windows 7 with xampp localhost ? i don't know xampp support python. Thanks in advance.


How to install Rpy2 for Python 2.6 on WINDOWS XP

I download the rpy2-2.2.3 , and try to : python setup.py install on my windows xp computer with R: 2.12.2 , Python: 2.6.1 , after copying some files, it shows below error msg. How to fix ? Traceback (most recent call last): File "setup.py", line 441, in &lt;module&gt; [os.path.join('doc', 'source', 'rpy2_logo.png')])], File "D:\Python\lib\distutils\core.py", line 152, in setup dist....


python - Can't install IMDbPY on windows

I'm having trouble installing IMDbPY on my windows computer. I think there is something wrong with my c compiler, because when I try to install it with easy_install or pip it gives me an error along these lines: C:>easy_install IMDbPY Searching for IMDbPY Best match: IMDbPY 4.9 Adding IMDbPY 4.9 to easy-install.pth file Using c:\python27\lib\site-packages Processing dependencies for IMD...


python - rpy2 install on windows 7

I'm trying to install rpy2 on my computer, but I wasn't able to do it. I downloaded the source package and I tryed to install Rpy2 (rpy2-2.3.2) using the command python setup.py install. This is the result: running install running build running build_py running build_ext "C:\PROGRA~1\R\R-215~1.2\bin\R" CMD config --ldflags "C:\PROGRA~1\R\R-215~1.2\bin\R" CMD config --cppflags "C:\PROGRA...


python - How to install numpy 1.8 dev on Windows?

I'm trying to install numpy 1.8 dev on Windows. I cannot find any binaries, only 1.7.1. Does anyone know where to download it? Alternatively, I also tried to build numpy myself. I donwloaded the latest source from Github and ran python setup.py install, but I get an error RuntimeError: Broken toolchain: cannot link a simple C program. Here's some of the output. I have VS 2008 installed wit...


python - How to install PyQt5 on Windows?

When I try installing the PyQt5 on Windows using the command python configure.py I get this error: Error: Make sure you have a working Qt qmake on your PATH. I got the pyQt5 from PyQt5 Download. How can I install PyQt5? ...


How to install pango for Python on Windows?

Since ReportLab does not support Python 3 I am now attempting to generate PDF with cairo, which works but lacks text-wrapping support. The next step seems to require pango and its Python-bindings, but I cannot find any information on how to install this for Windows.


python - How do I install SciPy on 64 bit Windows?

How do I install SciPy on my system? For the NumPy part (that SciPy depends on) there is actually an installer for 64 bit Windows: numpy-1.3.0.win-amd64-py2.6.msi (is direct download URL, 2310144 bytes). Running the SciPy superpack installer results in this message in a dialog box:...


Error when install python mysql module on windows?

When i try to install mysql on windows i get this error MySQL-python-0.9.2&gt;python setup.py build running build running build_py running build_ext building '_mysql' extension error: Unable to find vcvarsall.bat


Install Plone egg as a Python module on Windows

I have a Plone site (Plone version 3.1.2) that I need to install a product called GrufSpaces on - (http://plone.org/products/grufspaces). However, it is a production site and so I can't easily take it down to upgrade Plone to 3.2+ in order to use buildout; using buildout would allow me to easily add Grufspaces (collective.groupspace.roles etc) as ...


python - How to install NumPy on Windows 64?

NumPy installer can't find python path in the registry. Cannot install Python version 2.5 required, which was not found in the registry. OK I have to modify the registry? I already modified %PATH% to point to the Python25 installation directory.


python - Install Trac on 64bits Windows 7

I'm configuring a new Developing Server that came with Windows 7 64bits. It must have installed Trac with Subversion integration. I install Subversion with VisualSVN 2.1.1, clients with TortoiseSVN 1.6.7 and AnkhSVN 2.1.7 for Visual Studio 2008 SP1 integration. All works fine! my problem begun when going to Trac installation. I install python 2.6 all fine. Trac hasn't a x64 windows installer...


python - Steps on howto install PySide on windows

I followed what they said at pyside.org but somehow i can't get it to work. I downloaded the two files that they are linking from their site (qt libraries and pyside for python 2.6) When I try one of their examples I get the following message: Traceback (most recent call last): File "2dpainting.py", line 28, in &lt;module&gt; from PySide.QtCore import * ImportError: DLL load failed: The specif...


How to install both Python 2.x and Python 3.x in Windows

I do most of my programming in Python 3.x on Windows 7, but now I need to use the Python Imaging Library (PIL), ImageMagick, and wxPython, all of which require Python 2.x. Can I have both Python 2.x and Python 3.x installed in Windows 7? When I run a script, how would I "choose" which version of Python should run it? Will the aforementioned programs be able to handle multiple versions of Python installed at once? I...


python - How do I install IMDbPY on Windows?

I would like to start using IMDbPY but I can't find a Windows installer on their site. What is the most simple way to install it? Is there a way to install it using my Python interpreter?


How to install Python for Apache on Windows?

I'm looking for the fast, easy (all default settings) way of installing Python on my windows machine so that Apache can use it. I currently have a Windows 7 installation with Apache and PHP working. I want to try and make some simple web pages in Python, just to play around with Python for a bit and learn a thing or two. I downloaded and installed Python 3.2 Python 2.7.2 (As advised below). What do I do ne...


Install Python Fabric on Windows

Closed. This question is off-topic. It is not curre...


macos - python install on leopard

I'll admit I'm completely dumbed by python install. Can someone help me on how to install module I want to play with PyGame, PyOpenGL etc. So I install them, but I everytime I type "import pygame" error message shows up. here's my environment so far. In .bash_profile PATH=${PATH}:/System/Library/Frameworks/Python.framework/Versions/Current/bin Using easy_install PyO...


python - How can I install pyCurl?

I used libcurl with no problems and used pyCurl once in the past. Now i want to set it up on my machine and dev. However i have no idea how to do it. I rather not DL libcirl files and compile that along with pycurl, i want to know the simplest method. I have libcurl installed on my machine. I am on Windows. I tried DLing the sources and use pycurl setup script, but I had no luck.


python - where does django install in ubuntu

I am looking for the init.py file for django. I tried whereis and find, but I get a lot of dirs.


python - Install mysqldb on snow leopard

I am trying to get started on working with Python on Django I am by profession a PHP developer and have been told to set up django and python on my current apache and mysql setup however I am having trouble getting the Mysqldb module for python to work, I must of followed about 6 different set of instructions, I am running snow leopard and have mysql installed natively it is not part of MAMP or similar. Please can some tel...


Install python 2.6 in CentOS

I have a shell that runs CentOS. For a project I'm doing, I need python 2.5+, but centOS is pretty dependent on 2.4. From what I've read, a number of things will break if you upgrade to 2.5. I want to install 2.5 separately from 2.4, but I'm not sure how to do it. So far I've downloaded the source tarball, untarred it, and did a ./configure --prefix=/opt which is where I want it to end ...


How to install 64-bit Python on Solaris?

I am trying to install Python 2.6 on Solaris by building the source on Solaris machine. I installed one this way and it appears that it is 32-bit. I downloaded some source tar ball as Linux or Unix for this purpose. Everything works well but I need 64-bit Python. I looked up the Python download site and there is no sepa...


macos - Install PyObjC on Python 2.6 on OS X 10.5?

OS X 10.5.8 came with Python 2.5, and had PyObjC already installed. I installed Python 2.6 from the python.org site, and PyObjC isn't there. I can't find a download to install PyObjC on my Python 2.6 install. Is checking out the PyObjC trunk and trying to build it my only choice? Will that work "out of the box"?


python - How do I install SciPy on 64 bit Windows?

How do I install SciPy on my system? For the NumPy part (that SciPy depends on) there is actually an installer for 64 bit Windows: numpy-1.3.0.win-amd64-py2.6.msi (is direct download URL, 2310144 bytes). Running the SciPy superpack installer results in this message in a dialog box:...


What should I install in order to be able to use GTK in Python on Ubuntu?

In my source code I have: import gtk But when I run the script with python3 script.py command I get the following error. What package should I install to get it working? Edit: my bad. here is the error: ImportError: No module named gtk Edit2: Thanks for the answer, kaizer.se. But I'm still getting an error message. Take a look at the following...


python - How to install pycairo on osx?

I am trying to install the pycairo (Python bindings for the cairo graphics library) under OSX. I started with easy_install pycairo and got: Requested 'cairo &gt;= 1.8.8' but version of cairo is 1.0.4 error: Setup script exited with Error: cairo...






Still can't find your answer? Check out these communities...



PySlackers | Full Stack Python | NHS Python | Pythonist Cafe | Hacker Earth | Discord Python



top